Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead
Solventando errores

Desde que pasé a distribuciones basadas en el sistema de paquetería .deb que recurrentemente he visto el siguiente error:


En donde nos dice que la nueva forma de añadir las llaves es almacenarlas en /etc/apt/trusted.gpg.d.

Si hacemos caso omiso del aviso vemos que al actualizar la lista de paquetes nos sale el warning, aquí un ejemplo con el repositorio de wazuh.


Así que vamos a darle una solución para que salga todo limpio de avisos y lo tengamos todo en la forma correcta de hacerlo. La solución pasa por bajar la llave pero pasar el parámetro --dearmor de gpg y decirle donde almacenarlo, y para muestra un botón que reza el dicho:



Si nos fijamos en la primera línea, después de la sentencia curl redirigimos el fujo a gpg --dearmor y este lo redirigimos al comando tee que enviará el flujo al output y al fichero que hemos indicado, /etc/apt/trusted.gpg.d/wazuh.gpg.

Ahora ya podemos actualizar sin recibir ningún aviso.

Un saludo!













Anaconda/Miniconda para múltiples usuarios
Disfruta de varias versiones de python en tu sistema sin complicaciones